Degraded Performance Affecting Multiple Verify Tenants

Incident Report for IBM Security

Update

We are continuing to investigate this issue.
Posted Jul 27, 2026 - 19:41 UTC

Update

We have implemented mitigation actions and are observing improved service performance across affected IBM Security Verify tenants.

Our engineering teams continue to closely monitor the environment to ensure service stability while the investigation remains ongoing. We will provide additional updates as more information becomes available.
Posted Jul 27, 2026 - 18:41 UTC

Investigating

We are investigating degraded performance affecting multiple IBM Security Verify tenants. Customers may experience increased latency, intermittent timeouts, authentication failures, and elevated HTTP 503 errors. Engineering teams are actively working to mitigate the issue and restore normal service. Further updates will be provided as they become available.
Posted Jul 27, 2026 - 17:02 UTC