Possible email/SMS/OTP issues on Verify environments

Incident Report for IBM Security

Resolved

the delays associated with email / otp delivery have been resolved
Posted Apr 24, 2025 - 09:35 UTC

Investigating

We are currently investigating this issue.
Posted Apr 23, 2025 - 21:25 UTC